+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    User Level 1
    Location
    , ,
    Member No: 203266 11724 is an unknown quantity at this point 11724's Avatar
    Join Date
    Sep 2016
    Posts
    1
    Rep Power
    0


    Yes | No

    E39 530i Engine misfire during cold starts and when engine at idle RPM for along time

    Hi,
    I have a 2002 BMW E39 530i with a M54 engine. I have an engine misfire issue during cold starts and becomes normal(no more misfire) when engine reaches its normal operating temp and when i switch off and re-start the engine. The engine misfire also re-appears when the engine has been in idle RPM for about 2 min or longer, and again if you re-start the engine the misfire is No more. I have isolated the misfire to the 3rd cylinder. I have changed all 6 coils and spark plugs, the airflow sensor and have done a compression test which shows no abnormalities. My engine compartment wires connecting the ignition coils to the ECU has been repaired. Could this trigger the above fault. Any suggestions or advise would be highly appreciated.
    Thanks,
    Best Regards,
    Nuresh.
    Reply With Quote Reply With Quote 162.158.165.52


  2. #2
    Registered Member
    Location
    Sundance Mesa, NM, United States
    Member No: 4328 jimlev will become famous soon enough jimlev will become famous soon enough jimlev's Avatar
    Join Date
    Oct 2000
    Posts
    20,003
    Rep Power
    40


    Yes | No
    Didn't you get an answer over on bimmerforums?
    Just a few mods.
    If it ain't broken make it better and quicker!
    Reply With Quote Reply With Quote 172.68.35.102

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum