+ Reply to Thread
Results 1 to 5 of 5
  1. #1
    Endel K.
    Guest
    Location
    , ,
    Member No: Endel K.'s Avatar


    Yes | No

    hard starting problem (long)

    This particular vehicle is my neighbor's car I'm trying to figure out for him. I'm a SAAB master tech, but have absolutely no
    BMW experience. I need help. The car won't start when it's cold (ambient air temp: 30 F). When the car is running if you snap
    the throttle, the car stalls and doesn't always restart very well. In order to get it started I have to give it a shot of carb
    cleaner. Once it's started, it will restart fine. I replaced the intank fuel pump because it had failed. After replacement, I
    measured fuel pressure while running and it was on spec. I measured fuel volume and it is also on spec. I measured
    residual pressure when the car was shut off and it was fine. I tested the voltage and ground at the cold start injector. It turns
    on for approximately 20 seconds when you initially start cranking the car. I tested the mass air flow sensor and even
    substituted a rebuilt part, but it made no difference. I checked for any intake leaks, but found none. The car came to me after
    having the crank sensors replaced. I tried swapping the crank sensor plugs in case they were incorrect. That made no
    difference. I found that when you snap the throttle with a noid light plugged in place of one of the injectors, the light goes out
    when you snap the throttle. I also replaced the fuel filter. Any info or suggestions would be helpful.


  2. #2
    Registered Member
    Location
    Winchester, MA, United States
    Member No: 92707 540sport is on a distinguished road 540sport's Avatar
    Join Date
    Nov 2003
    Posts
    5,060
    Rep Power
    18


    Yes | No

    What year and engine have you got there?

    It sounds like you know a lot more about diagnostics than I do, but have you read the codes and do they provide any other info?

    There is a lot of differences between the 6's and 8's. Some of the common problems with both are Idle control Valves gumming up. They can be removed and cleaned with carb cleaner, just fill em up, let it sit and shake it out. Later 6's also had problems with the Vanos controller (variable valve timing) it can be unplugged/bypassed to eliminate it as a cause.

    Not sure what the significance of the noid light is.
    You might try posting this on the main E39 board.

    Hope this helps,
    Vinny

    98 540i/6speed Arctic Silver/Grey
    3.15 Diff with Quaife Limited Slip
    Dinan Stage 2 clutch and flywheel, CAI, MAF
    front strut brace, exhaust & stage 4 software
    UUC short shifter, CDV deleted
    euro AE halogens, clear sides, smoked celis tails
    M5 fully functional mirrors
    Brakes, rims, tires & suspension coming soon

  3. #3
    Endel K.
    Guest
    Location
    , ,
    Member No: Endel K.'s Avatar


    Yes | No

    Re: What year and engine have you got there?

    It's a '87 325e. The original posting on the E30 forum was from my neighbor Steve, who's trying to fix my car. He's pretty sharp. The noid light going out shows that the injector is cutting out and not operating at that time when the throttle is snapped open. Apparantly all the injectors are acting like that.

  4. #4
    Registered Member
    Location
    Winchester, MA, United States
    Member No: 92707 540sport is on a distinguished road 540sport's Avatar
    Join Date
    Nov 2003
    Posts
    5,060
    Rep Power
    18


    Yes | No

    Re: What year and engine have you got there?

    OK, sorry, my mindset was in E39 5 series mode when I answered your above post. I'll admit that I know very little about the E30's but that has never stopped me from diagnosing arcane problems via the internet before :-) You probably don't have an idle control valve and definately don't have Vanos.

    Did you see the reply to you post from chuck on the E30 board. Have you guys got the E30 repair manual? You may need to get the car to a BMW machanic, and I mean an independant shop, for proper diagnosis.

    Anybody else have any ideas?
    Vinny

    98 540i/6speed Arctic Silver/Grey
    3.15 Diff with Quaife Limited Slip
    Dinan Stage 2 clutch and flywheel, CAI, MAF
    front strut brace, exhaust & stage 4 software
    UUC short shifter, CDV deleted
    euro AE halogens, clear sides, smoked celis tails
    M5 fully functional mirrors
    Brakes, rims, tires & suspension coming soon

  5. #5
    Endel K.
    Guest
    Location
    , ,
    Member No: Endel K.'s Avatar


    Yes | No

    Re: What year and engine have you got there?

    It's got an ICV, and I know it works. I appreciate all the input from everyone. It's starting to look like I'll have to get it to a BMW shop like you suggest. Steve's an excellent mechanic and very thorough. The day the new crank sensors were put in, ($400.00 in diagnosis and $200.00 parts) I drove it for over 100 miles, no problem. The next day I put in a bottle of Techron Fuel injection cleaner, drove about 2 miles and that's all she wrote. It's just baffling to us why it's acting like that when all things seem to check out within specs.

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum