+ Reply to Thread
Results 1 to 6 of 6

Hybrid View

  1. #1
    Registered Member
    Location
    , ,
    Member No: 35512 ABS is an unknown quantity at this point ABS's Avatar
    Join Date
    May 2002
    Posts
    55
    Rep Power
    0


    Yes | No

    arp head stud torque

    hi guys would u torque ur head studs the same as factory spec or more for turbo m10?
    your thoughts?

  2. #2
    Hugo
    Guest
    Location
    , ,
    Member No: Hugo's Avatar


    Yes | No

    I usually torque them up 110%. No problems.


  3. #3
    ABS
    Guest
    Location
    , ,
    Member No: ABS's Avatar


    Yes | No

    Re: I usually torque them up 110%. No problems.

    the reason why i asked was i wasnt going to use arp head studs i found a place with head studs and also bolts with almost the same specs as arp for lets say $40 aud comapered to $200 aud...
    my friend has a pair from the same place i was going to buy the bolts , the fact is that he broke his head studs on his car and had to go and get new ones he paid $30 and his been boosting to 20+ psi and hasnt had any probs but its a not bm its a z18 turbo nissan motor so i thought well it should be fine for my application aslo he been drving it for a while

    your thoughts guys

  4. #4
    John N.
    Guest
    Location
    , ,
    Member No: John N.'s Avatar


    Yes | No

    If you spend the money for ARP studs and don\'t

    _exactly_ follow their installation instructions, you've just pissed away the $100 you spent.

    These are carefully engineered products that require accurate torque to get the clamping force you want.

    If you've lost the instructions, give them a call. You're also going to need to buy some Permatex high temperature thread locker (white tube) otherwise the rear headbold will leak like a MoFo.


    Regards,

    John N

  5. #5
    dhs
    Guest
    Location
    , ,
    Member No: dhs's Avatar


    Yes | No

    If you didn't use them when motor was honed too


  6. #6
    davide30
    Guest
    Location
    , ,
    Member No: davide30's Avatar


    Yes | No

    about burning oil

    I start my e30 turbo this weekend and the car run good but burn lot of oil and i dont know why . it's not PCV because I vent it to the atmosphere.
    please let me know !!!



+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum