+ Reply to Thread
Results 1 to 11 of 11

Hybrid View

  1. #1
    frank
    Guest
    Location
    , ,
    Member No: frank's Avatar


    Yes | No

    need some more help

    i have a turbo e30 garrett t3 t04e 57 trim turbo greedy profect b boost controller

    2 problems
    it starts spooling around 5000 rpms anything i can do to this turbo to get it to spool sooner
    and it will only boost to about 12lbs with the boost controller turned all the way up i know 12 is alot but not when it starts spooling before you shift
    thanks for the help
    frank

  2. #2
    Paul
    Guest
    Location
    , ,
    Member No: Paul's Avatar


    Yes | No

    Re: need some more help

    Post your settings from the profect b, is it a spec II?
    Also need to know what turbine housing you have on the T3 and what stage it is?

    What are you using for a wastegate? What displacement and CR is your engine?

  3. #3
    frank
    Guest
    Location
    , ,
    Member No: frank's Avatar


    Yes | No

    Re: need some more help

    it is a spec II its a 57 trim stage 3 tiAL external wastegate its a e with an i head motor and the compression is down to about 8/1

  4. #4
    Paul
    Guest
    Location
    , ,
    Member No: Paul's Avatar


    Yes | No

    Re: need some more help

    57 trim is the compressor side, need to know the A/R of the turbine housing should be .48 or .63 or .82 perhaps.

    List the settings of your boost controller, I have the same one and its a bit of a challenge to setup.

  5. #5
    frank
    Guest
    Location
    , ,
    Member No: frank's Avatar


    Yes | No

    Re: need some more help

    i belive its a .48 the balence is all the way to the left the low is set at 4lbs and high stops between 10 and 12 lbs

  6. #6
    Paul
    Guest
    Location
    , ,
    Member No: Paul's Avatar


    Yes | No

    Re: need some more help




    Is it this one? Your settings didn't make much sense.

    I'm running a T04E '50' with .48A/R stage 3 T3 on my M10, which is 2.1L and 9:1 CR. I get 12 psi before 3000rpms. Have you tried turning off your boost controller and letting the wastegate spring handle boost? I assume you can adjust the spring pressure on your wastegate. It's possible you have a leak either at the wastegate or perhaps in the pressure tubing to the intake manifold.

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum