+ Reply to Thread
Results 1 to 10 of 10
  1. #1
    Registered Member
    Location
    , ,
    Member No: 116807 carlo77777 is an unknown quantity at this point carlo77777's Avatar
    Join Date
    Nov 2004
    Posts
    1
    Rep Power
    0


    1 out of 1 members found this post helpful. Yes | No

    please help my heater is not working

    hey whats up everybody i have a 2000 jaguar s type 3.0 i bought it a week ago for a really good deal. The only thing wrong with the car is that the heater is not sending out hot air ? has this happend to anyone else ? and how do i fix it ? please get back to me. the heater works but no hot air.


  2. #2
    sixkiller
    Guest
    Location
    , ,
    Member No: sixkiller's Avatar


    Yes | No

    Re: please help my heater is not working

    I think you have an air bubble in the cooling system of the engine, i dont know exactly how the system works because it also has airconditioning, but the air bubble prevents hot water to stream through the heater.

    So you probably need to fill the radiator reservoir with some coolant and then bleed the radiator (i hope that this is good english ;))

    I dont know if there is somewhere an airvalve, but if it is, it is most likely fitted on top of the radiator.I did it a long time on an old car with no aircon, but i filled the radiator reservoir, started the engine and turned the airvalve open till there only gushed water out, and i shaked the car a little bit, but i doubt that worked ;)

    Good luck

  3. #3
    Bud Salyer
    Guest
    Location
    , ,
    Member No: Bud Salyer's Avatar


    Yes | No

    Re: please help my heater is not working

    Good chance it is a clogged/defective heater control valve. About $225 from suppliers. Don't know where it is located. Haven't looked. Doesn't look too complicated to change. Didn't have time to bother with it myself. Cost me $500 +/- to have a "European Auto" shop diagnose and replace.

    Bud Salyer

  4. #4
    Vic
    Guest
    Location
    , ,
    Member No: Vic's Avatar


    Yes | No

    Re: please help my heater is not working

    Look in your coolant recovery bottle. If the level is not lesss than 2 inches from the cap, low coolant level will prevent the heater from working. If it is low, you may have a cracked bottle. Coolant would leak out from the area just below the driver's feet, onto the ground.

  5. #5
    Tony
    Guest
    Location
    , ,
    Member No: Tony's Avatar


    Yes | No

    Re: please help my heater is not working

    Just noticed same issue with my 2000 jaguar 3.0.
    How did you fix it?

  6. #6
    Registered Member
    Location
    Greenville, NC, United States
    Member No: 117566 zapna is an unknown quantity at this point zapna's Avatar
    Join Date
    Dec 2004
    Posts
    22
    Rep Power
    0


    Yes | No

    Re: please help my heater is not working

    I also have not had heat in my 2000 3.0. I just checked my coolant reservoir and it was low. After filling, I got nice warm air! Hopefully, you will have the same luck.

  7. #7
    colin titley
    Guest
    Location
    , ,
    Member No: colin titley's Avatar


    Yes | No

    Re: please help my heater is not working

    please help,im freezing to death,s type 2000 can anyone help my heater blows cold air only except when reaching
    high speed when it appears to be ok, as soon as i slow down to normal speed its back tocold again help!.anyone

  8. #8
    Registered Member
    Location
    Greenville, NC, United States
    Member No: 117566 zapna is an unknown quantity at this point zapna's Avatar
    Join Date
    Dec 2004
    Posts
    22
    Rep Power
    0


    Yes | No

    Re: please help my heater is not working

    I am assuming you already checked your reservoir level, but just in case; these are the exact symptoms I had and as soon as I filled the reservoir up, I had hot air. I hope this is your problem and you simply didn't see my earlier post. Good Luck!

  9. #9
    james
    Guest
    Location
    , ,
    Member No: james's Avatar


    Yes | No

    help air conditioning not working, blowing fuse

    Out of now where this morning my air conditioning started blowing hot air. The fuse is blown in the engine compartment for the air conditioning clutch, but when I replace it the same thing happens. Please help with any ideas.

  10. #10
    jag
    Guest
    Location
    , ,
    Member No: jag's Avatar


    Yes | No

    Re: please help my heater is not working

    Well I had almost the same problem.I got a 2000 s type 3.0.When the car is idle or goin not more than 35 40 mph the heat and ac won't work, as soon as I pass 40 mph they both work fine.The problem is the vacum door of the heatin-ac system.I don't know more about it but if anyone does please feel free to let us know

+ Reply to Thread


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
1e2 Forum